MacOS High Sierra 10.13 Compatibility

The 2017 versions of AccountEdge are compatible with macOS 10.13 High Sierra with the latest compatibility updates installed.

U.S. customers will need to install v2017 release r21.0.11 or later. Canadian customers should install v2017 r21.3.2 or later.

Users running older versions of AccountEdge should consider upgrading to the latest version of AccountEdge (AccountEdge 2017) before installing macOS 10.13 High Sierra. Versions 2016 and earlier are not fully compatible and will experience issues registering the software as well as various user interface issues.

As a reminder, older MYOB versions of AccountEdge 2011 or earlier and AccountEdge Basic v1 and v2 are no longer supported and are not going to be able to register, activate or confirm AccountEdge on later operating systems. Customers should consider to upgrading to the latest versions of AccountEdge in order maintain compatibility.

For more information on compatibility with other Mac OS's and previous versions please see:

Mac OS X 10.12 Sierra Compatibility

Mac OS X 10.11 El Capitan Compatibility

Mac OS X 10.10 Yosemite Compatibility

Older versions of Mac OS X Compatibility