System Requirements for Processing Payments and TLS

In order to securely process credit cards and use our processing partner Forte’s payments gateway, AccountEdge users will need to ensure that they are using supported versions of AccountEdge and operating systems.

Merchants may have received notifications from Forte regarding their renewal and updating of their SSL certificate as well as retiring older versions of TLS. TLS which stands for Transport Layer Security is the method/protocol which your computer and software connect to servers securely to transmit data. Previous TLS versions, v1.0 and 1.1, are being retired and will no longer be recognized as PCI Compliant since they have been deemed less secure than the latest v1.2 protocol. These new TLS requirements are a result of an update to the Payment Card Industry Data Security Standard (PCI DSS).

Mac

AccountEdge
In order to securely process credit cards with AccountEdge, users will need to be running AccountEdge 2017 or later with the latest updates installed.

Operating System
You will also need to ensure that your computer is running an operating system that supports TLS 1.2. Supported operating systems include Mac OS 10.9 and later.

Earlier versions of MacOS do not support this newer version of TLS and pose a security risk. Many software vendors, banks, etc. no longer support OS’s and browsers that do not support TLS 1.2.

Windows

AccountEdge
In order to securely process credit cards with AccountEdge, users will need to be running AccountEdge 2017 or later with the latest updates installed.

Operating System
You will also need to ensure that your computer is running an operating system that supports TLS 1.2.

Windows 7 with Service Pack 2 and .Net 4.5.2 installed or later operating systems. When installing AccountEdge, the installer will typically automatically install Microsoft’s .Net Framework 4.5.2 which is required by AccountEdge and other software.

Earlier versions of Windows do not support this newer version of TLS and pose a security risk. Many software vendors, banks, etc. no longer support OS’s and browsers that do not support TLS 1.2.

Browser
Internet Explorer 11 or later is also required for processing. AccountEdge uses some of IE’s components when displaying Forte’s hosted secure web pay form for entering payment information.

Earlier versions of Internet Explorer are no longer supported and older operating systems and browsers are no longer receiving security updates. It is highly recommended that users upgrade to Internet Explorer 11 or Microsoft Edge. For more information you can read Microsoft’s “Support for older versions of Internet Explorer ended.”